Outreach and Newsletter Degraded Performance
Resolved
After a period of monitoring, this issue is now resolved. The application continues to function as expected. Outreach and Newsletter statistics are no longer delayed.

Thank you for your patience.
Posted Jan 27, 2020 - 14:08 UTC
Monitoring
Engineering has resolved the issue. Outreach and Newsletter statistics are now available. We will continue to monitor the system closely.

We apologize for any inconvenience caused and thank you for your patience.
Posted Jan 24, 2020 - 21:51 UTC
Investigating
Users should be able to create, edit, view, and send Outreach emails and Newsletters now. We are currently investigating delays in statistics for both Outreach and Newsletters.

We apologize for any inconvenience caused and will keep you updated on our progress.
Posted Jan 24, 2020 - 15:53 UTC
Monitoring
Our engineering team has located and resolved the issue. We will continue to monitor the platform and keep you updated.

We apologize for any inconvenience caused and we thank you for your patience.
Posted Jan 24, 2020 - 03:14 UTC
Investigating
Users may experience issues when creating an Outreach email or a Newsletter using an Approved Sender due to an ongoing incident with our external email provider. We are working with them to help resolve this as quickly as possible.

We apologize for any inconvenience caused and will keep you updated on the progress.
Posted Jan 23, 2020 - 21:54 UTC