Searches: Performance Degradation
Resolved
This incident has been resolved.
Posted May 20, 2020 - 07:32 UTC
Update
After a period of monitoring, this issue is now resolved. The application continues to function as expected and the most recent content is available.

We apologise for any inconvenience caused and thanks for your patience.
Posted May 20, 2020 - 07:31 UTC
Monitoring
Our engineering team has resolved the issue. Previously delayed content and added content should now be available within the platform. We will continue to monitor the system closely.

We apologize for any inconvenience caused.
Posted May 19, 2020 - 15:19 UTC
Identified
We are currently experiencing a delay in new content appearing in search results.

Users are now able to save and/or delete searches without further issues

We apologize for any inconvenience caused and will continue to update accordingly.
Posted May 19, 2020 - 11:26 UTC
Update
The root cause of this issue has been resolved and the users should be able save or delete searches without any issues. We will continue to monitor the system and keep you updated.

We apologize for any inconvenience caused and thank you for your patience.
Posted May 19, 2020 - 10:41 UTC
Monitoring
We are currently experiencing an issue where users are seeing errors on saving/deleting a search.

Our engineering teams are currently investigating. We apologise for any inconvenience caused and thank you for your patience.
Posted May 19, 2020 - 10:41 UTC
This incident affected: Search and Reports.