MI Platform – Login Issues
Resolved
After a period of monitoring, this issue is now resolved. Our login functionality continues to work as expected, with no further issues reported from our third-party provider.

We apologize for any inconvenience caused.
Posted Jul 22, 2021 - 20:33 UTC
Monitoring
Our third-party provider reported that this issue has been resolved. All users should be able to log in successfully now. We will continue to monitor the application.

We apologize for any inconvenience caused and thank you for your patience.
Posted Jul 22, 2021 - 17:33 UTC
Update
Our third-party provider continues to work towards full resolution. As they progress, some users may be able to log into the platform.

Thank you for your patience and we will continue to provide updates accordingly.
Posted Jul 22, 2021 - 16:57 UTC
Update
Engineering has determined the cause to be an issue with a third-party provider. We continue to work with them towards a resolution.

We apologize for the inconvenience and thank you for your patience.
Posted Jul 22, 2021 - 16:18 UTC
Investigating
We are currently experiencing issues with the Login page. Some users may be unable to log into the platform. Our Engineering team is currently investigating.

We apologize for the inconvenience and will continue to provide updates accordingly.
Posted Jul 22, 2021 - 16:02 UTC