Engage X/Twitter DM content disruption

Update

Our Engineering team continues to investigate the issues impacting receiving X DMs in Engage Conversations.

We apologize for the inconvenience and thank you for your patience.
Posted Oct 29, 2025 - 21:20 UTC

Investigating

We are currently experiencing an issue with receiving X DMs in Engage Conversations. Our Engineering team is aware of the issue and is actively working to resolve it.

We apologize for the inconvenience and thank you for your patience.
Posted Oct 28, 2025 - 14:54 UTC