Meltwater Engage Platform Degradation

Resolved

After a period of monitoring, this issue is now resolved. Loading of Owned Social accounts, including Publish, Conversations, and Owned Social Connections, is now functioning as expected.
Posted Aug 24, 2026 - 08:09 UTC

Monitoring

Our Engineering team has identified and resolved the issue affecting the Engage Platform. Users should now be able to access Engage as expected across Conversations, Publisher, Analyze, and Owned Social Connections. The team will continue to closely monitor the situation to ensure continued stability.

Thank you for your patience.
Posted Aug 20, 2026 - 15:16 UTC

Investigating

We are currently investigating an issue impacting the Engage Platform. Customers may experience errors when loading Engage Conversations, Publisher, Analyze Owned widgets and Dashboards, and Owned Social Connections. Our team is actively working to identify and resolve the issue. We will continue to provide updates accordingly.
Posted Aug 20, 2026 - 14:17 UTC
This incident affected: Application, Search, and Reports.