Explore - Performance Degradation
Resolved
This incident has been resolved.
Posted Mar 18, 2023 - 09:45 UTC
Monitoring
Explore searches continue to function as expected.

We will monitor the platform and provide updates accordingly.
Posted Mar 17, 2023 - 15:20 UTC
Update
The Engineering team has fixed the issue and Explore functions as expected. We will continue to monitor the application.

Thank you for your patience.
Posted Mar 17, 2023 - 11:23 UTC
Investigating
We are experiencing issues where users may see error messages while performing Explore searches. 

Our Engineers are aware of the issue and are currently working on a resolution. We will continue to provide updates accordingly. 

We apologize for the inconvenience and thank you for your patience.
Posted Mar 17, 2023 - 09:01 UTC