Our engineering team has resolved the issue impacting Outreach delivery. Outreach emails are now sending and analytics updating. We are monitoring the situation closely and will continue to provide updates accordingly.
Posted Sep 15, 2026 - 19:53 UTC
Investigating
We are currently experiencing an issue within Media Relations where there may be a delay in sending an Outreach email. Our Engineering team is aware of the issue and is actively investigating. We will continue to provide updates accordingly.
We apologize for the inconvenience and thank you for your patience.
Posted Sep 15, 2026 - 18:33 UTC
This incident affects: Application, Search, and Reports.