Meltwater Engage - Degraded Performance
Resolved
After a period of monitoring, this issue is now resolved. Social Connections continue to load on the Social Connections page and in Engage.

Thank you for your patience.
Posted Mar 08, 2024 - 21:39 UTC
Monitoring
Engineering has resolved the loading issue with Engage and Social Connections. We will continue to monitor the application.

Thank you for your patience.
Posted Mar 08, 2024 - 13:30 UTC
Update
Engineering has resolved the loading issue with Engage and Social Connections. We will continue to monitor the application.

Thank you for your patience.
Posted Mar 08, 2024 - 13:29 UTC
Update
Users may change their default language to English to resolve the issue.
Posted Mar 08, 2024 - 09:15 UTC
Investigating
We are currently experiencing an issue with loading Engage and Social Connections.
This impacts non-English language users. Engineering is aware of this and is currently investigating. We will continue to provide updates accordingly.

We apologize for the inconvenience and thank you for your patience.
Posted Mar 08, 2024 - 09:11 UTC