After a period of monitoring, this issue is now resolved. Explore continues to function as expected.
Posted Jun 04, 2025 - 14:36 UTC
Monitoring
The issue affecting Explore has been addressed by our Engineering team and the platform is operating as expected.
We will continue to monitor the application and provide updates accordingly.
Posted Jun 03, 2025 - 17:01 UTC
Investigating
We are currently experiencing intermittent issues with Explore searches not loading as expected. Our engineering team is actively investigating the cause.
We apologize for the inconvenience and will provide updates as soon as we have more information.