Issues Saving and Sending Newsletters
Resolved
After a period of monitoring, this issue is now resolved. Newsletters continue to function as expected.
Posted Feb 23, 2024 - 16:25 UTC
Monitoring
Newsletters continue to save and send as expected.

We will continue to monitor this issue and provide updates accordingly.
Posted Feb 22, 2024 - 20:36 UTC
Update
Engineering has resolved this issue and Newsletters are saving and sending as expected. We will continue to monitor the application.
Posted Feb 22, 2024 - 18:28 UTC
Investigating
Some users may experience issues saving and sending Newsletters, including previews. Our Engineering teams are working to resolve this as quickly as possible.

We apologize for any inconvenience caused and will keep you updated.
Posted Feb 22, 2024 - 17:31 UTC