Explore Performance Degradation
Resolved
After a period of monitoring, this issue is now resolved. Explore searches continue to function as expected.
Posted Aug 30, 2023 - 20:25 UTC
Monitoring
The Engineering team has fixed the issue and Explore is functioning as expected.

We will closely monitor the system and continue to provide updates.

Thank you for your patience.
Posted Aug 29, 2023 - 14:51 UTC
Update
Engineering continues to work to resolve this issue. Some users may experience intermittent errors while performing Explore searches.

We will continue to provide updates accordingly. Thank you for your patience.
Posted Aug 25, 2023 - 19:47 UTC
Investigating
Our Engineering team continues to investigate performance issues with Explore. Users may see error messages while performing searches.

We will continue to provide updates accordingly. Thank you for your patience.
Posted Aug 24, 2023 - 07:56 UTC
Monitoring
The Engineering team has fixed the issue and Explore is functioning as expected.
We will closely monitor the system and continue to provide updates.

Thank you for your patience.
Posted Aug 23, 2023 - 11:09 UTC
Investigating
We are experiencing issues where users may see error messages while performing Explore searches.
We will provide updates accordingly.

We apologize for the inconvenience and thank you for your patience.
Posted Aug 23, 2023 - 09:06 UTC