X/Twitter Authentication Issues
Resolved
Users may continue to intermittently experience the authentication issue for new connections and reconnections for X/Twitter Owned Connections within Engage. If you are having issues connecting as above the recommendation from X/Twitter is:


To remove cookies related to Twitter.com from your browser. (For your personal web browser please follow their recommended steps for clearing your cookies.)
If that does not resolve the issue they recommend temporarily disabling two-factor authentication in X/Twitter and then reconnecting in the Meltwater platform during this time. (You can then re-enable two-factor authentication in X/Twitter.)



We'll resolve this incident now, however should you experience further issues please reach out to our Meltwater Help team at help@meltwater.com.
Posted Aug 30, 2024 - 17:25 UTC
Update
Our Engineering team is still actively working with X/Twitter on the intermittent authentication issues in Engage, where users may be redirected to the X/Twitter homepage instead of Meltwater.

Thank you for your patience.
Posted Aug 14, 2024 - 21:02 UTC
Update
Our Engineering team continues to work with X/Twitter regarding the intermittent issues when authenticating X/Twitter accounts in Engage. Users may be redirected to the X/Twitter home page instead of Meltwater.

We apologize for the inconvenience and thank you for your patience.
Posted Jul 15, 2024 - 20:32 UTC
Investigating
We are currently experiencing intermittent issues with authenticating or re-authenticating X/Twitter accounts in MI Engage. Users may be redirected to the X/Twitter home page instead of Meltwater. Engineering is aware and working with X/Twitter to resolve the issue.

We apologize for the inconvenience and thank you for your patience.
Posted Jul 10, 2024 - 18:14 UTC
This incident affected: Application, Search, and Reports.