After a period of monitoring, this issue is now resolved. Engagement data continues to flow into the platform as expected.
Posted Aug 08, 2025 - 15:04 UTC
Monitoring
Our Engineering team has resolved the issue that was causing delays in Engagement metrics. The latest engagement data is now fully updated on the platform.We will continue to monitor and provide updates accordingly.
Thank you for your patience.
Posted Aug 07, 2025 - 14:56 UTC
Investigating
We are currently experiencing delays in retrieving the latest Engagement metrics, including Social Echo data for all content. Engineering is aware of the issue and is currently working on fixing it.
We apologize for the inconvenience and thank you for your patience.