Users may experience trouble in receiving Newsletters
Resolved
After a period of monitoring, this issue is now fully resolved. Newsletter distributions continue to function as expected.

We apologize for any inconvenience caused.
Posted May 20, 2020 - 19:29 UTC
Monitoring
Newsletter distributions are now being sent successfully. We will continue to monitor the system and keep you updated.

Thank you for your patience.
Posted May 20, 2020 - 11:51 UTC
Investigating
We are currently investigating an issue where some users are not receiving newsletter distributions.

We apologize for any inconvenience this causes and will keep you updated on the progress.
Posted May 20, 2020 - 10:52 UTC