Delay in YouTube data

Resolved

After a period of monitoring, this issue is now resolved. Youtube content is flowing in as expected.
Posted Jul 02, 2025 - 10:55 UTC

Monitoring

Our Engineering team has completed backfilling the YouTube content.
We will continue to monitor and provide updates accordingly.
Posted Jul 02, 2025 - 07:16 UTC

Investigating

We are currently experiencing an issue receiving public YouTube data. This may impact the Explore data. Our Engineering teams are currently investigating the issue.

We apologize for any inconvenience caused, and thank you for your patience.
Posted Jul 02, 2025 - 02:48 UTC
This incident affected: Application, Search, and Reports.