Issues Loading MI Engage Conversation Tab
Resolved
After a period of monitoring, this issue is now resolved. The Engage Conversations tab continues to work as expected.

Thank you for your patience.
Posted Jun 01, 2023 - 15:15 UTC
Monitoring
Engineering has resolved the issue and Engage Conversations tab is now functioning as expected. We will continue to monitor the status of the application.

Thank you for your patience.
Posted May 31, 2023 - 11:56 UTC
Investigating
We are currently experiencing an issue with the Engage Conversation not loading in the application. Mobile users will also experience this issue. Engineering is currently investigating.

We apologize for the inconvenience and will continue to provide updates.
Posted May 31, 2023 - 09:56 UTC